Raspberry Pi Dedicated Issue


#1

When running ioq3ded.arm, it’s not really updating the master servers.
I put in a bug request on gh: https://github.com/raspberrypi/quake3/issues/8 but maybe it’s a pebkac error.


#2

This old version of ioquake3 doesn’t properly handle communicating with masters with IPv4 disabled. It’s fixed in ioquake3 git master.

net_enabled 2 only enables IPv6. The server uses NA_UNSPEC to get a IP address for master and gets an IPv4. Then when it goes to send it, the server doesn’t have an IPv4 address and drops it.

Try net_enabled 3 instead to enable both IPv4 and IPv6.


#3

we can’t update or fix that fork of ioquake3, unfortunately.


#4

Would be nice if RPI support was added into the main. =/


#5

I await a suitable pull request.


#6

What version of SDL is needed?
There’s a fork - which I can’t get to compile (couldn’t find the SDL.h file - which I tried 1.2.x beta and 2.2.x): https://github.com/twolife/ioq3


#7

we use SDL 2 now, that version is probably using SDL 1.2.12 or something old like that.


#8

I was able to update that fork last summer with the current version of ioq3 and got it to compile.


#9

I did find this -https://github.com/ilmen-sandbox/ioquake3_dedicated_server - haven’t tried to compile yet.


#10

Let me know if you need any help. I can post the Makefile and raspberrypi.sh script if you need those. I did a git merge on the fork this afternoon and there’s only three files that have a conflict.


#11

So it looks like https://github.com/ilmen-sandbox/ioquake3_dedicated_server uses the old code. =(
Really trying to push for IPv6 stuff. =)


#12

Hey - anything to push one of the greatest games out to all platforms is good. Keeping it updated it better. =)


#13

fwiw I neglected to mention that the official Q3 and ioq3 master servers do not have an IPv6 address. dpmaster.deathmask.net does, which might be useful for testing IPv6-only server but probably not many people look for Q3 servers there. If you want the default master servers to work, you have to use net_enabled 3 (for IPv4+IPv6) instead of net_enabled 2 (for IPv6) even if you update to latest ioq3 code.


#14

I thought IOQ master supported IPv6. If I do net_enabled 3 - but only have the IPv6 firewall would it still work?!


#15

That sounds good…


#16

I don’t know. I am not knowledgeable about firewalls.


#17

Firewalls = allow/deny. Some allow you port map (great if you only have 1 address - IPv4 - or you need to force a change of an external port number to another, if the host application can’t change which port it’s on).

In my case, I could map the server via IPv4, but I don’t want to, I want to be an IPv6 only host.


#18

Cdev: Did you ever post that stuff up on Github?


#19

Cdev: Had any time targeting the Raspberry Pi platforms?


#20

Yes, I’ve put a lot of time into this over the past three months. It’s a lot of work for one person but it’s nearly complete. I’ll post a link to GitHub when it’s ready.