What are the basics of AAS generation?

I have been struggling for a couple of hours to generate a working .aas file for my maps for ioquake3.

I am using GtkRadiant 1.6.4 and the ubiquitous bspc 2.1h that comes with GtkRadiant.

I have tried to make three very simple maps but none of them work.

Basically I have a small map, two rooms, two info_deathmatch_starts and a couple of lights.

I compile the (full) bsp with GtKRadiant. That goes well, I can load into ioquake via "map <foo_test> and it works.

I then try to compile the .aas file.

bspc will only generate the .aas file if I use the switch “-forcesidesvisible”. Otherwise is says the aas bsp is leaked due to external entities.

I then have my foo.bsp and foo.aas in the same directory.

I run ioquake3 with sv_pure 0 and then map foo

In game I then try to run bots and I am told that “AAS has not been initilaized”.

Other maps, that have existing .aas file (default quake3 maps) work perfectly.

Therefore I was wondering if any had a small map they sould share which was built in a recent GtkRadiant and they know works with the AAS system?



  1. The basics of creating an AAS file can be found inside the Radiant manual or here:

  2. If you have installed Radiant correctly, Radiant will ask you where your quake3.exe is installed. There should be sample maps inside your working directory of your Quake III installation than (q3dm1sample.map. q3dm7sample, etc.) You can try to compile those and see if everything will work as intended.

  3. Make sure no entity is outside the world (void) or inside brushes.

  4. Make sure to use the correct switches when compiling with bspc. If you are not used to command line parameters use a frontend utility which does most of the job for you, e.g.: a tool called Q3map2Build

  5. Make sure you really have the created AAS file in the correct directory when loaded into game, coupled with the matching bsp file. If you are not sure, put foo.bsp and foo.aas into a foo.pk3, inside your baseq3 directory.

Other than that, I have no idea what went wrong.