Texture clipping

The default explosion animated textures always clip on walls. Is there a way of avoiding this behavior?

Probably by using soft particles. Though ioq3 does not have support for them.

Are these considered soft particles? http://www.quake3hut.co.uk/q3coding/Explosion%20Particles.htm

No, unfortunately this is nothing about soft particles. Though you can shift the sprites along an axis (moving away from walls etc.)
Sprites clipping on walls is a very annoying behavior!
This are soft particles:

It seems as if soft particles are planned for ETLegacy project: http://www.etlegacy.com/issues/322
I hope this will help you a bit!

1 Like

Seems hard to implement. I don’t think ioq has a depth buffer. :frowning:

Since there is some SSAO in ioq3, I think there is a depth buffer somewhere … But yeah, it sounds hard to implement …

There’s SSAO in ioq? :open_mouth:

Yes, to enable it, switch to opengl2 renderer (cl_renderer opengl2) and then type “r_ssao 1” in the console. But it’s quite dirty at the moment, and you can’t setup it further more in the console.

You might want to read this : https://github.com/ioquake/ioq3/blob/master/opengl2-readme.txt

It appears to be here: https://github.com/ioquake/ioq3/blob/master/code/renderergl2/tr_fbo.c#L165

But the buffer doesn’t seem to be used. Just created and cleared, as a copy of the render buffer.

try to check out the ssao render code to see how it uses the depthbuffer … I’m sorry I’m really not into hacking the render engine :slight_smile:

Yeah, it’s very difficult for people without GL background like me. I’m just starting and the whole ioq3 codebase is already overwhelming. Imagine implementing new stuff! However, i’ve been analyzing the code for other engines, like Warsow, and trying to hack my way in.