Ogg audio (MinGw)


#1

Title says it all : I would like to use .ogg format for my music to save some space, but how do I switch this on when I compile ?

Thanks !


#2

make USE_CODEC_VORBIS=1 or create a file named Makefile.local and put USE_CODEC_VORBIS=1 in it. Or you could use Ogg Opus (which is enabled by default) which should be better quality at same size vs Ogg Vorbis.


#3

Hy there. I want to use Opus, or Ogg without new compiling. Is that possible?


#4

ioq3 test builds have opus support enabled.


#5

Why you dont enable OGG by default? Creating Opus files is terrible in Windows machines… And Opus… I never heard about it before. :smile:


#6

I don’t know why Ogg Vorbis is not enabled.