Ioquake3 Installation Problems with Ubuntu 18.04


I’m following a few guides on the internet to install ioquake. I’ve done it before a few times but never on 18.04. When I run the ioquake3-1.36-7.1.x86_64 after chmod etc I am getting a weird terminal installer screen (I can’t remember that last time) and then it won’t let me install into /usr/local/games as it says ‘no write permission’.

Can anyone help?

You need root privilege to write there. You may be able to accomplish this by running the following:

sudo ./

However you could skip installing using the old 1.36 .run script and just use an ioquake3 test build (contrary to the name it’s recommended for everyone to use). I forget if the .run script installs some menu shortcuts though.

1 Like


I installed this but I think I messed up. It installed into usr/local/games so I can’t alter the config or anything.

How do I remove ioquake from this location and start again?

What I don’t understand is this little chomebook was running 16.04 and it installed fine in my Home directory and the install windows for ioquake was normal GUI. But now I have installed 18.04 all the install screens are terminal screens and it installs in usr? What’s going on?

Hmm… when I run ./ on Debian 8 I get a GUI installer not a terminal-based installer. Maybe Ubuntu 18.04 doesn’t have GTK+ 2 libraries or something installed by default anymore so it falls back to a terminal interface.

The config is saved in /home/yourusername/.q3a/baseq3/. You can install pk3s there as well. The only reason you should have to change /usr/local/games/ioquake3/ is to update ioquake3.

Adventures in uninstalling on Linux x86_64

Copy the lines that don’t start with # into a terminal and run them. The state of installing/uninstalling ioquake3 is rather unfortunate.

This assumes ioq3 was installed using sudo and installed in /usr/local/games/ioquake3. /root/ is the home directory for the root user (accessed using sudo).

# Fix uninstaller failing to find loki-setup uninstaller on x86_64.
# It needs a link named amd64 that points to the x86_64 directory.

sudo ln -s /root/.loki/installed/bin/Linux/x86_64 /root/.loki/installed/bin/Linux/amd64

# Fix uninstaller failing with the following error due to using dash shell instead
# of bash:
# /usr/local/games/ioquake3/.manifest/scripts/ 16: /usr/local/games/ioquake3/.manifest/scripts/ Syntax error: Bad fd number
# It needs to replace ">& /dev/null/" (used to silence any output in Bash)
# on line "rmdir --ignore-fail-on-non-empty demoq3 missionpack >& /dev/null"

sudo sed -i -e "s|>\& /dev/null|>/dev/null 2>\&1|" /usr/local/games/ioquake3/.manifest/scripts/

# Run the uninstaller

sudo /usr/local/games/ioquake3/uninstall

# If it fails to uninstall then report the text output to this thread and don't run
# the commands below.

# Check if any games are installed using loki-setup, if there is then don't remove
# .loki in the next step

sudo ls -l /root/.loki/installed/*.xml

# WARNING only if the uninstaller succeeded and you don't have any other loki-setup
# games installed in /root/.loki/installed/*.xml then run this to remove left over
# files from the installer
sudo rm -r /root/.loki

Installing in home directory

You can install ioquake3 in any directory you want.

To use the installer; run ./ (no sudo) and change the install path to be in your home directory (i.e., /home/yourusername/ioquake3). You cannot change location after installing. Then run the ioquake3 linux q3a data installer to install baseq3/pak[1-8].pk3 and menu shortcuts for Q3A and Team Arena. Then to update ioquake3, extract the test build in the same directory you choose as the install path.

Alternatively you can skip the installer. The main loss is the installer will add ioquake3 to the system menu and PATH for running ioquake3 from a terminal. Extract the test build somewhere in your home directory, add baseq3/pak[0-8].pk3 (get pak[1-8].pk3 here if needed), and you’re good to go. To run it you have to open a terminal and change to where you extracted it using “cd Downloads/ioquake3” (or where ever you extracted it) and then enter ./ioquake3.x86_64.

The config will always be saved in /home/yourusername/.q3a/baseq3/ in any case.