How can i build 64-bit .qvm files for windows?

i create a 64-bit exe with msvc and all the .dll files too:

cgamex86_64.dll
gamex86_64.dll
uix86_64.dll

but when i start the game it says: VM_Create on UI Failed.

i think the game doesnt read the .dll files. it seeks for the .qvm files.

my questions:
how can the game read the .dll files?
how can i create the .qvm files in 64-bit?

Start the game with +set sv_pure 0 +set vm_cgame 0 +set vm_game 0 +set vm_ui 0.

MSVC support does not include qvm building. You’ll need to build them on linux or mingw.

okay i tried to deactivate vm_ui, vm_game, vm_cgame and sv_pure in all cfg files and +set sv_pure 0 +set vm_cgame 0 +set vm_game 0 +set vm_ui 0 in file linkage.

still doesnt work:

Try adding +set developer 1, it might show where it’s trying to load the dll from.

I’d guess one of these locations;

  • D:\Zeq2\Game\Base64\uix86_64.dll
  • D:\Zeq2\Game\Base64\uix64.dll

okay now the qvm/dll problem is fixed. i just rename the “x86_64” to “x64” like "uix64.dll"
thank you!

but now the next problem!

i have no models to select and no sound!

here the console:

i think the dll’s cgame and qagame was not found. i try to delete both files and the game starts up with the same problem. it only loads the uix64.dll file and the other both dll’s was ignored by the game. why?

when i try to start a match in the game than i have this error:

game and cgame are loaded with you start a map. cgame is loaded when you join a server.

i know but when i start a map i have the error VM_Create on game failed. the error tells me that game is missing like the previous error that telled me that ui was missing.

what can i do now? rename the file qagamex86_64.dll? to what? i renamed it qagamex64.dll and still doesnt work but to rename the uix64.dll worked.

please help.

Does +set developer 1 show where it tries to load game dll from?

okay the problem is solved too. i just rename qagamex64.dll to gamex64.dll

now all dll files are correct. but now the next problem when i start a map:

-EDIT-

okay i solved the problem with +set com_hunkmegs 2047

but the next problem, oh my goooood…

Hmm. Signal 11 means it crashed. You could try to build Debug and run in debugger to find where it crashes.