Help installing ioQuake3

So installing ioQuake3 isn’t running as easily as I thought it would.
I downloaded the installer and ran it. I tried simply copying the files from the ioQuake3 folder into my regular quake3 folder because I thought that would be easiest. However when I ran the ioQuake3 exe, I found that it was actually just running regular Quake 3, not the ioQuake3. I thought this was weird.

Just for kicks I tried running ioQuake3 in its original folder, hoping it would give me an error that tells me what files are missing. It gave me an error that said it could not find the quake 3 files, and it was looking in the “program files” directory. I don’t see any kind of config file I can edit to tell it to look in my GOG folder instead.

I suppose I could copy over the quake 3 files from the quake 3 folder to the ioQuake3 folder, but this always bugs me because I don’t know exactly what files a given source port wants, and I could not find a simple guide to that information within any of the readme files in the ioQuake3 folder.
(Seriously, it is very unconventional for a source port to not just tell me what files from the original version I need to copy over to get it to work.)

How exactly am I supposed to properly install this?
The instructions on the site say to also download a data installer, which honestly sound weird and sketchy, and since it talks about taking extra steps if I have a Steam copy, I suspect it wasn’t built to work with GOG copies either, so it doesn’t sound like what I need.
The directions in the readme file talk more about the source code than what I already have installed, and focus on linux and mac versions without mentioning windows.

I am sorry, we had a major hacking incident in June (the builds you downloaded today should be fine, but they’re from 2009!) and it has taken me a long time to get the project back to the point where we have working test builds and can then get better installers and such. I will address your other issues as best I can, but the long and the short of it is that the files for download on ioquake3.org today are old and almost useless and the updated binaries we provided before are not currently available due to the hacking incident.

We should find out if there is a way to detect quake3 files installed by gog, but we are also working on another solution that could work around that issue of finding the files almost entirely.

The data installer was only really built to handle (if I remember correctly) data from cd-roms and possibly if Quake 3 had been installed (again, from a cd-rom).

I do need to update that README because it was originally written from the perspective of someone seeking Linux and Mac support, and then for modders & game makers as well. Our wiki with better documentation is also offline [but can be browsed via the internet archive.](http://web.archive.org/web/20180926205015/http://wiki.ioquake3.org/Players_guide

The best, and only, way to run ioquake3 until the hacking issues is resolved and the websites have been moved is to compile it yourself or from a trusted friend and get a binary that you can just place in the ioquake3 directory next to or over the original one you downloaded.

The files you need to copy are the pak0.pk3 to pak9.pk3 (or whatever the highest number is) from your original baseq3 directory to the ioquake3 baseq3 directory.

Holy floop, I did not expect to hear that your project getting hacked.
I actually have an older install on my main computer already, (I installed it a year or so ago, and right now I’m looking into installing it on old machines I take to events to play old PC games,) but it looks like it is the same 2009 version you mentioned.

Should I really not trust the version I downloaded this week? Should I swap it out for the version I have on my main computer?

Maybe I didn’t word it well, the files you downloaded from ioquake3.org now are probably fine, they’re just old.

There was a set of what we call test builds they were compiled from source automatically whenever we changed something in our Git source code, but were more stable and recommend to every user. The test builds were (possibly) compromised back in June or earlier. Those test builds have not been available to download since June when we took them offline and discontinued the test build system based on Jenkins (the piece of software that automatically created the test builds). You will see these test builds referenced often in our documentation, website, and forums.

It’s not that you didn’t “word it well” per se, but you did contradict yourself.
You said that the version I got was fine, but then later said the only way to run it was to compile it myself or get a copy from a friend. But I guess the latter statement was made toward the test builds.

Personally I tend to avoid test builds because official builds are promised to be more stable.

Okay well I got the information I was looking for. Thanks for your help, and good luck getting the project back on track!

Yeah this was a mistake when I renamed the automatic builds we create from source, it’s offputting that they’re called test builds when they are more stable and secure than the 2009 builds.

…Okay this is weird.
When I run ioquake3 on this computer, it is actually just running regular Quake 3.
I don’t have the options to set a widescreen resolution (literally the only reason I’m installing this) and the second page of credits doesn’t appear when I exit. This is exactly what happened when I tried dropping the ioquake3 files into my quake3 directory, but this is happening in my ioquake3 directory after dropping in my baseq3 and mission pack folders.

Not sure what the problem here is.
This computer is running Windows XP; not sure if that might be an issue. Don’t know what else to look for.

If you bring down the console with the shift+escape or the key to the left of the 1 key on your keyboard’s number row and see an ioquake3 version-string on the right-hand side of the console, then it’s just using the baseq3 qvm and not a problem, you can still manually set the widescreen resolution with r_customwidth r_customheight and vid_mode -1

Okay, the console DOES display the version as ioq3 1.36, but when I type r_customwidth 1440 I don’t get any changes. The first time I tried changing it, it gave me a message saying that it would change the next time I started a game. But it never changed, and now it no longer displays that message.

I find it odd that it is even possible that the menu would not display the changes made to ioq3. If it is somehow reverting to a default of the original, I suspect many ioq3 features might be absent.

Nothing changes until you set the width, height, and then the r_mode and then either restart the game or do a /vid_restart in the console. This is all described in the Player’s Guide as well.

Okay, I got the resolution changed now.
Still, it’s odd and annoying that I can’t access the full menu change that I have on another machine that uses the same version.
But at least now I can set up proper resolutions for all my machines.