Wanna be ioquake3 user - bugreport

Hi guys! New forum? Well, what the hell… at least I can use a normal password there.

I downloaded the latest ioQuake 3 build, somewhat expecting that it can use properly 1280x1024 screen (Win7 64bit, i5 750, GTX 660), but it failed. Still, the screen is rendered wider and a bit off screen then… suxxx, if you ask me. There is how it looks in normal Quake 3 version 1.32c:

So basicaly this support for 1280x1024 was my first question and unless I did something wrong, then there is not much else I would do:
seta r_customaspect "1"
seta r_customheight "1024"
seta r_customwidth "1280"
seta r_customPixelAspect "1"
seta r_fullscreen "1"
seta r_mode "-1"
Or it is?

Next is my long time wish - to disable the scoreboard and make the letters/icons much smaller, about 1/3 of this:


I posted a thread about it there:

And when I get back, the forum is locked and that it is. So I get the pk3 file and added to config these lines:
seta cg_statusScale "0.6"
seta cg_drawStatusHead "0"
seta cg_drawPickups "0.6"
seta cg_drawWeaponBar "0.6"
seta cg_drawScores “0”

And while the head is gone (hoooray!), scoreboard and all the oversized letters / icons are still there, not smaller by one bloody bit. I assume that the patch to the code was not included in normal build version…?

And also there is a problem with the gamma. On normal Q3 I use the switch:
seta r_ignorehwgamma “1”
…to get nice colors, not darkened a lot image. Now it does not work on ioQuake3 x86 Win :frowning:

There is new switch that says:
seta r_ext_gamma_control “0”
…so I set it to off, but that did not help either… So, what should I do now?

BTW, no 64bit version of ioQuake3 for Windows, only for Linux? Hmmm. Well probably not really need, as the CPUs have enought power these days to run old good Q3 :slight_smile:

So, any chances that these issues can be resolved?

Not sure what version you’re using, but the latest builds are here:

I would recommend you try these and see if any of your issues are fixed. They say “test” but should be pretty stable. (Probably more stable than the released build which is more than 5 years old)

1 Like

Using the latest ioq3 with ztm-flexable-hud-r1.pk3 in baseq3, sv_pure 1, and the cvars you specificied I get


It does not change the scoreboard, center print, FPS size, and many other things as well.

MANATARMS - okay, I tried the build you pointed me to, tried the 32bit version to be safe… And only one thing that was improved is, that now the gamma works, eg. colors and brightness are back.

The screen 1280x1024 does NOT work. It only works in menu AND in the aftergame menu selection - not IN the game.

These cvars have still no effect.

zturtleman - how can I set the sv_pure in config? Like:
seta sv_pure “1”
…? I did not have anything like that in my config… yet. Gotta test if that helps anything, but I doubt it… NO CHANGE. I better provide my config:
…because it simply does not work for me at all.

I’m guessing it’s not loading the cgame from the flexable hud pk3.

Can you post a link to your console log? After loading a level run \condump log.txt in the console. It puts in homepath baseq3 folder. Then upload log.txt online somewhere.

No, not true, not working. I start the 1st level, write in console the \condump log.txt - it seems to work, but NO LOG.TXT file is anywhere on all my HDDs. Much less in baseq3 folder.
Only two txt files are in Quake3 root dir: botlib.log and stderr.txt

Also thre is third time, that I get sound bug in the ioQuake3 - witch never happened for me once in original Q3! (this time it was a stuck end of the “You win” sound playing after the level)
Before it was similar stuck sounds into gameplay… so ATM there are only bugses and quirks over the original Q3, while no improvement is detected for the game.
I mean - 1280x1024 working in MENU is nice, but I did not give rat’s ass about the menu. I focus on game, screw menu… And that simply does not work at all. Completely. You think that this is the flexable hud pk3 problem too? I see all you guys have a NICE custom resolutions, but it just dost not work for me at all… That is very VERY flustrating.

PS. found it! It is hidden in the lame Win7 app data directory:
%userprofile%\Appdata\Roaming\Quake3 …
Log is there: http://ax2.old-cans.com/log.txt

…and the config is also there to edit, not in the root dir, witch suxx :frowning: Time to check the config then.

Bump to make the 1280x1024 resolution to work!

Another slight bump? Anyone can tell me, what I doing wrong in order to get the 1280x1024 resolution to work for the game…? Not just for the menu? Please?

Please? There is my config:

Anyone can help?



That resolution works for me…That first screenshot doesn’t look like 1280x1024 to me. 1280x1024 isn’t wide aspect.

Try a fresh config.

Works for you? Sounds good, then what I’m doing wrong? What is your config, could you share it…?

No idea about what screenshot you talking about, sure as hell is not mine, I use only 1280x1024 res:

Fresh config? Ugh. Again? … Any other ideas?

PS. fresh config = no help!
There it is, no modifications yet done: http://ax2.old-cans.com/new_q3config.cfg

…and as you can see, still wrong pixel aspect:

Please help!

PS. find another bug. When have selected the Hunter “lightgun” weapon, there is a weird hum in speakers… No idea wtf this is, but it does not happen in original Q3 as far, as I remember.

If you’re talking about the UI being cut off on the right side, that happens in the legacy quake3 binary as well, not just in ioq3.

If you downloaded the build I linked you to above you should have a vm folder inside of the baseq3 folder. If you have that you shouldn’t be seeing that problem.

Try running with sv_pure 0 and see if the issue is still there.

The railgun has a hum sound whenever it’s selected.

MANATARMS - yes, I have the VM folder with the files cgame.qvm, qagame.qvm and ui.qvm in it. But the legacy Quake3 is buggy and the display is “not ending” on the right side of the screen (eg. cursor can go “behind” the visible screen).
isQuake have this fixed (or should have), but it only works on the main screen, on the “after level screens” it is still wrong :frowning:

The result should be like this:
Quake3 endlevel screen OKAY
…and NOT this: http://postimg.org/image/ep88618d3/

I would check on the sv_pure 0, it is 1 atm and we see…

TimeDoctor - I was not talking about railgun, but about light gun. That have no sound in Q3, IIRC. But that is easy to re-check :slight_smile:

PS. - checked the sv_pure 0 setting and it immediatelly render the screens after the gamelevel right! Hoooray!
…however it also screw up (they are not working) the added options that scale down (0.6 seems good, edited the 1st post accordingly) the ughly big fonts and allow me to disable things… :frowning: So these options:

seta cg_statusScale "0.6"
seta cg_drawStatusHead "0"
seta cg_drawPickups "0.6"
seta cg_drawWeaponBar "0.6"
seta cg_drawScores “0”

…with sv_pure 0 does not work, while they do work perfectly with sv_pure 1 … I claim a slight bug out there :slight_smile:

Railgun, Lightning Gun, and BFG have an idle sound.

sv_pure 0 will use unzipped qvms if present instead of ones in pk3s. This causes ioq3 to use the updated ioq3 vms, but it also prevents using the flexable hud cgame.

Here is an updated flexable HUD pk3: ztm-flexible-hud-r2.pk3 [EDIT (Nov 2017): Link Removed.]

It includes ioq3 game and ui qvms in the pk3. Now with sv_pure 1 you get the updated ioq3 game/ui with the flexable HUD cgame. Updated flexable HUD cgame also adds 3 new cvars. [EDIT (Nov 2017): Link to code patch removed.]

  • cg_stretch [0 - 1] 0 uses aspect correct HUD, 1 stretches 4:3 HUD to fit screen (default: 1)
  • cg_fovAspectAdjust [0 - 1] automatically convert 4:3 cg_fov values to current aspect (default: 0)
  • cg_fovGunAdjust [0 - 1] controls gun offset based on FOV. 0 uses Q3A code, 1 uses new code (works with FOV < 90 and fixed FOV dmflags) (default: 0)

EDIT (Nov 2017): The current version is at https://clover.moe/flexible-hud-for-ioq3/

I never noticed something so disturibing using Lighting Gun, but I check the original and report back.

As for the support for 1280x1024 - so I downloaded the pk3 file, deleted the old one and place it into the baseq3 directory.

Then I downloaded the latest (30.8.2014) ioQuake build, replaced all the files (one 200k DLL have now 4.2M?! - SDL2.dll ) with new ones, deleted the old files that are not present into the archive and… the game run at about 0.5fps :slight_smile:
That somewhat suxx, because Far Cry 3 can run at 100+ fps on my machine :slight_smile: Either I did something vey very wrong, or there is a bug?

Maybe double check if you updated the renderer_opengl1/2 dlls. I have no idea really.

I’m 100% sure that I updated everything. Still no go. So I reverted back to original Q3 (after all, it have so much less files need, lol) and done some testings about the alleged sound using light gun and railgun.

While I was able to hear a very very very low level sound of the railgun, I cannot confirm the light gun sound effect when choosed AT ALL. I simply did not hear and difference between it and other weapons (except rail). Quake 1.32c

Check for yourself. I still maintain that this IS a bug in ioQuake therefore. But no longer important bug, as ioQuake pracically does not work at all, so… no longer priority.

Original Q3 exe is 800kBy in size. ioQuake is 2.8MB in size and require about 2.9MB of DLL libs just in the programfile directory (libcurl-4.dll, openal32.dll, renderer_opengl1_x86.dll, renderer_opengl2_x86.dll) and 1.7MB of dlls in baseq3 dir (cgamex86.dll, qagamex86.dll, uix86.dll) and 1.1MB of the qvm files in the vm dir inside baseq3 dir.

800kBy vs 8.5MB WTF? :open_mouth: …and it does not even work, lol. What is going on there?

Hello Trodas: I’m no expert, but maybe I can help you. I had similar issues in the past.
You are talking about a few different ‘issues’ here, so, if I am allowed, I will sort them a bit:

Screen resolution issue:
Personally I always use r_mode -2 this should give you at least your current desktop resolution.
Can you try this? Open the console (default key ~) and type ‘/r_mode -2; vid_restart’

0.5 frame issue:
Yes I have the same problem, but only if I’m using the new renderer, this issue is only fixable with an ugly HACK (which I’m not allowed to say here again I think ;))
Though, the new renderer isn’t default, so are you sure you do use the default renderer?
Check this, open the console (default key ~) and type '/cl_renderer opengl1; vid_restart’
You should have at least as much frames as your com_maxfps setting will allow (iirc 85fps)
Though, comparing ioquake with Far Cry 3 is a bit too much I think.

File size issue:
The size of dlls, exe or whatever, doesn’t matter. I assume you have more free space on your HDD than 8.5 MB!!!
The size depends on many things happening during the process when the files are created, and end-user shouldn’t worry about that.
At least it should not be a fact to judge ioquake, or do a comparison of quake3 vs. ioquake3.
Trust me, I ‘wasted’ most of my lifetime with playing Quake3, and even I switched to ioqauke3.
Why do you want to praise Quake3? ioquake3 IS Quake3 with a lot of important features and updates Quake3 doesn’t have. https://github.com/ioquake/ioq3/blob/master/ChangeLog

Sound issue:
I also have ugly sound issues with ioquake, but only when I am using OpenAL.
ioquake implemention of OpenAL is a bit outdated I think, I never got good results. You can update to OpenALSoft, but some issues will still remain (i.e. playing many sounds at once sounds horrible)
So if you are on Windows I highly recommend to NOT use OpenAL, select SDL sound (default).
Open the console (default key ~) and type ‘/s_useopenal 0; snd_restart’.

Though, the lightning gun HAS an idle sound, and people like ZTURTLEMAN and MANATARMS and many other ioquake programmers (https://github.com/orgs/ioquake/people) are very experienced programmers, so if they tell you the lightninggun, railgun and BFG have an idle sound, well, then they have an idle sound :).
You can check this by yourself. Have a look at the original Quake3 source code:https://github.com/id-Software/Quake-III-Arena/blob/master/code/cgame/cg_weapons.c
scroll down to line 688. Here all the weapons are listed, every weapon with a ‘weaponInfo->readySound’ line will make an idle sound:
MAKERGB( weaponInfo->flashDlightColor, 0.6f, 0.6f, 1.0f );
weaponInfo->readySound = trap_S_RegisterSound( “sound/weapons/melee/fsthum.wav”, qfalse );
weaponInfo->firingSound = trap_S_RegisterSound( “sound/weapons/lightning/lg_hum.wav”, qfalse );

voilà :slight_smile:

1 Like

I absolutely use the original render, SEE MY CONFIG ABOVE. I posted that already long time ago…

Well, I give up. The slow-down is to terrible that you cannot convince me to go into ioQuake again. Simply unbearably slow, total lockup. So f*ck this, I’m back at original. Even it suxx, it does just work fine. No idea why just a few kBy of code works, while ioQuake fail to work completely.

Though, comparing ioquake with Far Cry 3 is a bit too much I think.

Why? This is absolutely stunning example. Far Cry 3 show like 100 to 1000x more details and it still run like breeze. ioQuake suddently cannot move my cursor? Come on…

File size does not matter? I tell you something. If ID software can code up Q3 that is ALMOST doing everything it should (at least it is working) with 870k, then 8.5MB is bloatware. Sure there migth be reasons for it, but ONE SIMPLE FILE, like ID do it, would be much nicer.

I’m not typical enduser and I always worry a LOT when I see crazy increase in size and it makes me wonder, what happend. It is not just about the capacity, but the fear of effectivity of so huge code is enormus.
BTW, if all there is is one executable file, then installing will not be that hard and there won’t be many dependancies and checkings and worring, if useg for this or user got that file in right version, etc. So there are reasons why keep things simple for the user…

LightGun does indeed have a NICE (albeit VERY quiet (in original Q3) sound. Now I detected it, it is almost unhearable if your PC is not superquiet and you had not turned the volume too much up. But regardless - ioQuake “version” of the sound sounds like 5x londer at least and totally wrong. Almost slike some static noise and not like the civilized original quiet Q3 sound.
That is what I noticed and what make me wonder, what kind of bug this is.

Nevermind, with original Q3 it is fixed.