Some help with SDL 2.0 or something

I’m at my third install of MinGW and MSYS. The wiki page for building ioq3 was ok… for being 6 years old… This is the first time I’ve been able to get MinGW and MSYS installed and working. I currently have a clean install of MinGW and MSYS, but even my old archived install is producing the same results…
I’m left at a serious crossroads. After following the breadcrumbs I found the latest ioq3 is using SDL 2.0. This was after following the outdated stuff and installing SDL1.2.4 or whatnot.
At some point it was working perfectly, but things have gone downhill and has degraded to the point where the ioquake3.x86.exe wont even start…
I’m using Windows professional 7, with Intel dual core…
I have seen things that tell me Windows may complicate things and many may not want to tackle this… but all I’ve had to work with was computer science pages that wanted to start me on basic SDL programming.
I’ve had between 4 to 6 different web pages telling me where to put the SDL2.dll and where not to put it… help.

Do you actually want to compile ioquake3? We have test builds up here:

Yes sir. I must build ioq3 myself. I’ve already done it once, and it’s gone bad since then, but I will start over again gladly.
I use the build to play…
I’ve been using the lcc compiler to do MOD’ing for the past 11 years.
I am putting together a new version of an old MOD. The newest modifications have changes to the engine including client, and the renderer… what say you.

I’m running msys2 with mingw packages installed and have no issues, I just use the following makefile.local:

DEBUG_CFLAGS=-gdwarf-2 -O0

#Enable the next two lines to compile for 32-bit
#WINDRES=windres -F pe-i386

#Enable the next two lines to compile for 64-bit

You shouldn’t need to download SDL2 separately, as the source code should come with headers and libraries. What are your exact errors, though?

1 Like

Appreciate that… I’m flying blind and hope this will work. I’ll try it first thing in the morning.
I’m getting no errors that I can see compiling, except for some opusfile-0.5 warnings…
The last thing I remember was following some directions for installing SDL and the next thing I know it’s looking in FooBar/foobar for the default.cfg that it can no longer find…
Now it’s telling me…
"The application was unable to start correctly (0xc000007b). Click OK to close the application."
If I go back to the distributed ioq3 build it works fine…

1 Like

Thank you for the feedback.
Smiletheory, I tried your suggestion, and no luck.
The 64bit wouldn’t compile, and the 32bit build had the same result of the build not starting correctly. I’m not sure I didn’t mess something up somewhere. But thanks.
MANATARMS, I’ll look at Cygwin, thank you for the suggestion.
Will get back on here and post the results of working on this further.

Installed with all the packages mentioned. Unfortunately this didn’t get me far. I put cgwin and bin into the PATH, rebooted, and got a whole string of problems… is this normal?
mintty not found…
/bin/sh: sed: command not found
something about cygiconv-2.dll loaded to different address…
make: Makefile:65 fork: Resource temporarily unavailable
some of these errors were repeated a lot more then others.
It ends with Makefile:536: *** Cannot find a suitable cross compiler for mingw32. Stop.
I’m perfectly willing to do the leg work and hunt everything down that I need. I see what you mean, it looks like a useful tool and if this is normal, I’m used to working for my goals. If this isn’t normal, and something went wrong else where, maybe it isn’t worth my time? Thanks.

May have answered my own question.
Re-ran setup-x86 with --no-admin and selected mintty…
it’s compiling now…
<- crossing fingers

Thanks for the input. After a bit of thought, even if it doesn’t compile 100% right now, it’s good enough for what I’m doing.
The results will be on sourceforge if successful.

Just a bit of feedback…
msys2 looks promising, but it did look a bit complicated, (it seemed to need a few extra files, or I’m just not experienced enough,) maybe later.
I did like Cygwin, it was simple and worked without much hassle.
Finally got MinGW and msys to work.
There was one site that pointed out some of the sourceforge files need their checksums validated, I may have gotten a bad one.
The ioquake3 wiki confused me, maybe it’s a different systems have special needs, kinda thing, but this site
Cleared up little things like the program ‘vi’ used to edit the fstab file, it’s a very picky, tricky program, and how to use it is slippery at best.
It was a space, NOT a TAB… picky bugger.
Compiling great… and we’re off!