Serverbrowser favorites not working - solved


i run three internal servers.
i added them as server1, server2, server3 to the config but it just displays “NO RESPONSE” in the server browser.
however, i can join them from there and also query them successfully with serverstatus ip:port.
also qstat receives the details.

it would be really great to get this working.
do you have any idea what could be the issue?


Please upgrade to a test build if you haven’t already

Let us know if that helps the issue or not.

i replaced the testbuild i used with the latest.
no, it did not change anything :confused:

do favorites require to talk to the master server?
both, server and clients are not able to do so.


Favorites don’t use the master at all

i can confirm it is somehow related to the server address.
i just started a local server and the client with the following addresses as favorites:

seta server1 ""
seta server2 "localhost:27961"
seta server3 ""
seta server4 ""

the interesting find was that the serverbrowser works as expected for server 1+3.
for server 2+4 it just displayed no response.

i will try to verify this on my other setup.

is there anything else i could check/verify?

after fixing the typo (wrong port) :slight_smile: it worked as well.
so right now i have the feeling it does not work well with a server name but ip addresses.
(on my other setup i used the server name)

i will keep you updated

yes, i can confirm, it works with the ip address!