Segmentation fault launching ioquake3 in Mint Linux 19


#1

Last time I played ioquake3 on my Mint Linux 19 PC I had no issues. That was at least a week ago.

Tonight I tried to play and I’m getting a Segmentation fault.

I’ve renamed the q3config.cfg to a .bak file, but still getting the segmentation fault.

Where would I find an error log showing what happened? Is there anything I can try to repair this?

I have already downloaded ioquake3 again and reinstalled with no change.

This is what I get when launching:

steve@MintPC:~/ioquake3$ ioquake3
ioq3 1.36 linux-x86_64 Apr 12 2009
----- FS_Startup -----
Current search path:
/home/steve/.q3a/baseq3/pak8.pk3 (9 files)
/home/steve/.q3a/baseq3/pak7.pk3 (4 files)
/home/steve/.q3a/baseq3/pak6.pk3 (64 files)
/home/steve/.q3a/baseq3/pak5.pk3 (7 files)
/home/steve/.q3a/baseq3/pak4.pk3 (272 files)
/home/steve/.q3a/baseq3/pak3.pk3 (4 files)
/home/steve/.q3a/baseq3/pak2.pk3 (148 files)
/home/steve/.q3a/baseq3/pak1.pk3 (26 files)
/home/steve/.q3a/baseq3/pak0.pk3 (3539 files)
/home/steve/.q3a/baseq3
./baseq3/pak8.pk3 (9 files)
./baseq3/pak7.pk3 (4 files)
./baseq3/pak6.pk3 (64 files)
./baseq3/pak5.pk3 (7 files)
./baseq3/pak4.pk3 (272 files)
./baseq3/pak3.pk3 (4 files)
./baseq3/pak2.pk3 (148 files)
./baseq3/pak1.pk3 (26 files)
./baseq3

----------------------
4607 files in pk3 files
execing default.cfg
couldn't exec q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
Your network rate is too slow for VoIP.
Set 'Data Rate' to 'LAN/Cable/xDSL' in 'Setup/System/Network' and restart.
Until then, VoIP is disabled.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----
SDL using driver "x11"
Initializing OpenGL display
Estimated display aspect: 1.778
...setting mode 3: 640 480
Segmentation fault (core dumped)
steve@MintPC:~/ioquake3$

#2

Well… I don’t know what the issue was but it’s working now after a second restart. Very odd indeed.


#3

Please upgrade to a test build https://ioquake3.org/get-it/test-builds/