Quake 3 Fortress on ioquake3 for Linux is console only?

Hello Guys, how are you?
I play ioquake3 on Linux and I want to play the Team Fortress mod (Q3F - Quake III Fortress).
I installed it and I can run it, but when the game starts, just the console is shown with the background image…
Everything works fine, but I can’t exit the console, see the attached Screenshot:

Image Link
What can I do to play Quake 3 Team Fortress on ioquake3?
Downloaded the mod here: http://www.moddb.com/mods/q3f

Looks like the dedicated server console mode. Is the “dedicated” cvar set?

I looked at q3config.cfg on the folder /q3f2/ and it has this line:

seta ui_dedicated “0”

When you have q3f open like the screenshot, type “dedicated” and press enter. It will print the current value of the console variable.

1 Like

The current value is 0.
Default: 0

Okay, it’s not in dedicated server console mode. Try launching the mod directly from a Linux terminal; ioquake3 +set fs_game q3f2.

What changes is that the intro vídeo is from Q3F, but the result is the same…

Here is the Linux terminal “console log”:

[details=linux-terminal (click to read)]~/ioquake3 $ ./ioquake3 +set fs_game q3f2ioq3 1.36 linux-i386 Apr 12 2009
----- FS_Startup -----
Current search path:
./q3f2/q3f_ultima.pk3 (95 files)
./q3f2/q3f_tf2k.pk3 (70 files)
./q3f2/q3f_openfire2b.pk3 (75 files)
./q3f2/q3f_h4rdcore.pk3 (31 files)
./q3f2/q3f_dungeonz.pk3 (46 files)
./q3f2/q3f_crossfire2.pk3 (105 files)
./q3f2/q3f2_pak2.pk3 (596 files)
./q3f2/q3f2_pak1.pk3 (115 files)
./q3f2/q3f2_pak0.pk3 (2988 files)
./q3f2/duel1r2.pk3 (23 files)
./q3f2/allduel.pk3 (46 files)
./baseq3/vdamaged.pk3 (11 files)
./baseq3/underwater.pk3 (9 files)
./baseq3/pak8.pk3 (9 files)
./baseq3/pak7.pk3 (4 files)
./baseq3/pak6.pk3 (64 files)
./baseq3/pak5.pk3 (7 files)
./baseq3/pak4.pk3 (272 files)
./baseq3/pak3.pk3 (4 files)
./baseq3/pak2.pk3 (148 files)
./baseq3/pak1.pk3 (26 files)
./baseq3/pak0.pk3 (3539 files)
./baseq3/lvl_vdamaged.pk3 (2 files)
./baseq3/bdog3dm1.pk3 (45 files)

8330 files in pk3 files
execing default.cfg
execing q3config.cfg
com_zoneMegs will be changed upon restarting.
execing autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
----- Initializing Renderer ----

QKEY found.
----- Client Initialization Complete -----
----- R_Init -----
SDL using driver “x11”
Initializing OpenGL display
Estimated display aspect: 1.779
…setting mode -1: 1366 768
Using 8/8/8 Color bits, 24 depth, 8 stencil display.
Available modes: ‘1366x768 640x360 720x405 864x486 960x540 1024x576 1280x720 680x384 1360x768 640x480 800x600 1024x768’
GL_RENDERER: Mesa DRI Intel® Haswell Mobile x86/MMX/SSE2
Initializing OpenGL extensions
…ignoring GL_EXT_texture_compression_s3tc
…ignoring GL_S3_s3tc
…using GL_EXT_texture_env_add
…using GL_ARB_multitexture
…using GL_EXT_compiled_vertex_array
…ignoring GL_EXT_texture_filter_anisotropic

GL_VENDOR: Intel Open Source Technology Center
GL_RENDERER: Mesa DRI Intel® Haswell Mobile x86/MMX/SSE2
GL_VERSION: 3.0 Mesa 11.2.0
GL_EXTENSIONS: GL_ARB_multisample GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_copy_texture GL_EXT_polygon_offset GL_EXT_subtexture GL_EXT_texture_object GL_EXT_vertex_array GL_EXT_compiled_vertex_array GL_EXT_texture GL_EXT_texture3D GL_IBM_rasterpos_clip GL_ARB_point_parameters GL_EXT_draw_range_elements GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_separate_specular_color GL_EXT_texture_edge_clamp GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_ARB_framebuffer_sRGB GL_ARB_multitexture GL_EXT_framebuffer_sRGB GL_IBM_multimode_draw_arrays GL_IBM_texture_mirrored_repeat GL_3DFX_texture_compression_FXT1 GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_transpose_matrix GL_EXT_blend_func_separate GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_secondary_color GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_INGR_blend_func_separate GL_NV_blend_square GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_S3_s3tc GL_SUN_multi_draw_arrays GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_EXT_framebuffer_object GL_EXT_texture_compression_s3tc GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_MESA_window_pos GL_NV_packed_depth_stencil GL_NV_texture_rectangle GL_ARB_depth_texture GL_ARB_occlusion_query GL_ARB_shadow GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_window_pos GL_EXT_stencil_two_side GL_EXT_texture_cube_map GL_NV_depth_clamp GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_shader GL_ARB_shader_objects GL_ARB_vertex_program GL_ARB_vertex_shader GL_ATI_draw_buffers GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_MESA_pack_invert GL_NV_primitive_restart GL_ARB_depth_clamp GL_ARB_fragment_program_shadow GL_ARB_half_float_pixel GL_ARB_occlusion_query2 GL_ARB_point_sprite GL_ARB_shading_language_100 GL_ARB_sync GL_ARB_texture_non_power_of_two GL_ARB_vertex_buffer_object GL_ATI_blend_equation_separate GL_EXT_blend_equation_separate GL_OES_read_format GL_ARB_color_buffer_float GL_ARB_pixel_buffer_object GL_ARB_texture_compression_rgtc GL_ARB_texture_float GL_ARB_texture_rectangle GL_EXT_packed_float GL_EXT_pixel_buffer_object GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_rgtc GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_shared_exponent GL_ARB_framebuffer_object GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_packed_depth_stencil GL_APPLE_object_purgeable GL_ARB_vertex_array_object GL_ATI_separate_stencil GL_EXT_draw_buffers2 GL_EXT_draw_instanced GL_EXT_gpu_program_parameters GL_EXT_texture_array GL_EXT_texture_integer GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_OES_EGL_image GL_AMD_performance_monitor GL_ARB_copy_buffer GL_ARB_depth_buffer_float GL_ARB_draw_instanced GL_ARB_half_float_vertex GL_ARB_instanced_arrays GL_ARB_map_buffer_range GL_ARB_texture_rg GL_ARB_texture_swizzle GL_ARB_vertex_array_bgra GL_EXT_texture_swizzle GL_EXT_vertex_array_bgra GL_NV_conditional_render GL_AMD_conservative_depth GL_AMD_draw_buffers_blend GL_AMD_seamless_cubemap_per_texture GL_ARB_ES2_compatibility GL_ARB_blend_func_extended GL_ARB_debug_output GL_ARB_draw_buffers_blend GL_ARB_draw_elements_base_vertex GL_ARB_explicit_attrib_location GL_ARB_fragment_coord_conventions GL_ARB_provoking_vertex GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_seamless_cube_map GL_ARB_shader_texture_lod GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_multisample GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_uniform_buffer_object GL_ARB_vertex_type_2_10_10_10_rev GL_EXT_provoking_vertex GL_EXT_texture_snorm GL_MESA_texture_signed_rgba GL_NV_texture_barrier GL_ARB_get_program_binary GL_ARB_robustness GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_texture_compression_bptc GL_ARB_timer_GL_MAX_TEXTURE_SIZE: 8192

PIXELFORMAT: color(24-bits) Z(24-bit) stencil(8-bits)
MODE: -1, 1366 x 768 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
rendering primitives: single glDrawElements
picmip: 1
texture bits: 0
multitexture: enabled
compiled vertex arrays: enabled
texenv add: enabled
compressed textures: disabled
Initializing Shaders
----- finished R_Init -----
------ Initializing Sound ------
Loading “libopenal.so.0”…
Failed to load library: “libopenal.so.0”.
SDL audio driver is “pulse”.
Format: AUDIO_S16LSB
Freq: 22050
Samples: 256
Channels: 2
Starting SDL audio callback…
SDL audio initialized.
----- Sound Info -----
1 stereo
8192 samples
16 samplebits
1 submission_chunk
22050 speed
0x9e84a50 dma buffer
No background file.

Sound initialization successful.

Sound memory manager started
Loading vm file vm/ui.qvm…
VM file ui compiled to 731614 bytes of code
ui loaded in 8762624 bytes on the hunk
Parsing menu file:ui/ui/main.menuu
Parsing menu file:ui/ui/menubar.mmenu
Parsing menu file:ui/ui/menu_playy.menu
Parsing menu file:ui/ui/menu_setuup.menu
Parsing menu file:ui/ui/menu_extrras.menu
Parsing menu file:ui/ui/menu_helpp.menu
Parsing menu file:ui/ui/menu_favoourites.menu
Parsing menu file:ui/ui/findgame…menu
Parsing menu file:ui/ui/serverinffo.menu
Parsing menu file:ui/ui/password…menu
Parsing menu file:ui/ui/connect.mmenu
Parsing menu file:ui/ui/creategamme.menu
Parsing menu file:ui/ui/findplayeer.menu
Parsing menu file:ui/ui/options.mmenu
Parsing menu file:ui/ui/resetdefaaults.menu
Parsing menu file:ui/ui/controls…menu
Parsing menu file:ui/ui/loadconfiig.menu
Parsing menu file:ui/ui/classconffig.menu
Parsing menu file:ui/ui/classconffig_selec.mmenu
Parsing menu file:ui/ui/classconffig_discards.menu
Parsing menu file:ui/ui/classconffig_load.menu
Parsing menu file:ui/ui/system.meenu
Parsing menu file:ui/ui/favouritees.menu
Parsing menu file:ui/ui/modmmenu"
Parsing menu file:ui/ui/movies.meenu
Parsing menu file:ui/ui/demos.mennu
Parsing menu file:ui/ui/specify.mmenu
Parsing menu file:ui/ui/credits.mmenu
Parsing menu file:ui/ui/error.mennu
Parsing menu file:ui/ui/five_slidde_1.menu
Parsing menu file:ui/ui/five_slidde_2.menu
Parsing menu file:ui/ui/five_slidde_3.menu
Parsing menu file:ui/ui/five_slidde_4.menu
Parsing menu file:ui/ui/five_slidde_5.menu
UI menu load time = 1 milli seconds
Parsing menu file:ui/ud/ingame.meenu
Parsing menu file:ui/ud/endgame.mmenu
Parsing menu file:ui/ud/usermenu…menu
Parsing menu file:ui/ud/coms_1_0…menu
Parsing menu file:ui/ud/coms_1_1…menu
Parsing menu file:ui/ud/coms_1_2…menu
UI menu load time = 0 milli seconds
— Common Initialization Complete —
IP6: ::1
IP6: fe80::7c7c:4498:5121:abf%wlp6s0
Opening IP6 socket: [::]:27960
Opening IP socket:
Wrote screenshots/shot0005.jpg
Unknown command “exit^7”
----- CL_Shutdown -----
Closing SDL audio device…
SDL audio device shut down.
RE_Shutdown( 1 )[/details]

I tested Q3F with recent ioq3 on Linux and it worked. So I would suggest trying the test build.

Thanks! I’ll try it.
You downloaded the same Q3F as I did?

To install this new build I just extract the files and overwrite the old ones?

Yeah, Quake 3 Fortress 2.2 FULL from the link you posted.

You can extract the files over the top or somewhere else; which ever you want.

How can I put the com_hunkmegs 96 in the Q3F?

In the Linux terminal run;

ioquake3 +set fs_game q3f2 +set com_hunkMegs 256

96 hunkMegs wasn’t enough so I increase it to 256.

IT worked! Thanks :slight_smile:
Do you know if q3f has bots?

1 Like

It does not appear to have bots.

Q3F 2.3 was the final released version. Then it got ported to Splash Damage’s free Wolfenstein Enemy Territory as “ETF” which mustered up to version 1.6.

ETF does have some pretty basic bots but I’m not sure if you can find a good Linux release these days. Especially with the bot support enabled.