Pixelformat, I can't change it to 32-bit


First of all, warn that English is not my native language. Apologies if I can’t make myself understood and appreciate the enormous work behind this sourceport for this great timeless game.

I’m having problem setting the 32-bit color. When I start ioQuake, it appears in the console:

PIXELFORMAT: color (24-bit) Z (24-bit) stencil (8-bit)

I have tried to change it from system setup/graphics, from the menu. It is set to 32 but the console still shows 24.

From the autoexec file (I know in ioQuake it is in %appdata%):

seta r_colorbits “32”
seta r_depthbits “24”
seta r_stencilbits “8”

And from q3config.exe:

seta gl_pixelformat “color(32) depth(24) stencil(8)” <-(It already came by default).

In addition, the previous commands continue to appear with the same values (r_colorbits, depth…).

Quake3e show 32-bits, but it does not support OpenAL and for me that is decisive enough to be in IoQuake.

Is there any solution? Thanks for everything.

Edit: I have done a clean install and Quake 3, vanilla, also plays in 32-bit; it is when applying ioQuake when it is set to 24.

It seems like ioquake3 drops the colorbits from 32 to 24 in the code though I’m not sure why yet, I’m hoping to find out for you. (this was incorrect)

1 Like

Thank you very much for the help. I’ve been trying everything for several days, but there’s no way.

I really don’t appreciate a decrease in image quality, it must be really subtle, but those numbers indicate that it’s there.

I’ve used both renderers (OpenGL1-2) with predefined settings and it doesn’t seem to work. Also, I’ve tried all the commands I know and that I’ve been finding in different forums, but I’m afraid my knowledge doesn’t go much further. I hope you succeed.

I asked an expert I’ve known for years and there should be 0 difference between 24 and 32. The extra 8 bits are used for alpha channel (transparency) only, no colors should be different functionally. I’m still not sure why it appears to be clamped.

A more technical explanation: each channel of RGB (red, green, blue) gets the same 8 bits of color between 24 and 32. The extra 8 are like just for alpha transparency channel.

Also, I just ran ioquake3 on windows 11 with a recent geforce card and can’t reproduce the issue. Once I set r_colorbits 32 with the in-game console and did a /vid_restart it sticks.

When did you download ioquake3?

What graphics hardware do you have?

Check our players guide for help configuring ioquake3: Players Guide – ioquake3

I downloaded ioquake3 a few days ago from this link: Download ioquake3 – ioquake3

I’m using Windows 10. My graphics card is an NVIDIA GeForce GTX 1650 with a 165Hz monitor.

I’ll check the guide you provided and continue searching for a solution.

1 Like

Is it possible that it’s running in 32-bits even though the console displays 24?

When I input the command r_colorbits 32, nothing happens. However, when I switch to r_colorbits 24, it indicates that I need to restart: “r_colorbits will be changing upon restarting” (when it was supposed to be already at 24), and it also defaults to “default” in the system setup/graphics configuration.

If I input r_colorbits 32 again, it asks me to perform a vid_restart, and despite the console showing 24, the system setup displays 32.

I believe there might be an odd desynchronization between the console and the configuration, unless the only valid information is what the console is displaying.

Thank you for your patience.

it is very unlikely. The console is displaying the definitive value and all values should match after the game is entirely restarted. A vid_restart may not clear the game menu setting. The in-game GUI “System” menu may not be working properly, but that is just a very old piece of software that is difficult to fix because it is contained in the pak files that come with quake 3. We do make changes to it rarely, but the changes are usually lost once you join a game server and quit out due to the nature of the “pure” system in quake 3. Other mods and games may behave better.

How is the monitor connected to your computer?


Through DisplayPort, since the monitor has AMD FreeSync and I have an NVIDIA, thus making it compatible with G-Sync.

Do you think that could have something to do with it? Quake3e runs in 32-bits using the same cable. I’m unaware of how different the sources are between them.

I have HDMI, but I would lose those refresh rates.

Not anymore, just wanted to make sure this wasn’t a situation with less than a digital signal, something like an analog VGA cable could perhaps misbehave. In any case, I wouldn’t worry about it because there should be no loss of quality going from a 32bit to 24bit. I will still try and reproduce the issue.

1 Like