macOS Sierra oddities

Having rendering issues between ioquake3-1.36 and the latest beta.
Please see:

Top image is ioquake3-1.36 (fine) and the second is the beta (not so good).

This is happening both with a set up, configured .cfg as well as a clean install.

Any idea what is causing this?
Could a simply .cfg setting fix things?


Should have stated, this only happens with Quake 3 Arena using single player skirmish, Team Death Match.

Playing with (and lowering) gamma settings seems to help a bit.

Maybe it’s related to the new renderer. Try opening the console using ~ and running

cl_renderer opengl1; vid_restart

You can switch back to the new renderer using

reset cl_renderer; vid_restart

1 Like

what graphics chipset does your mac have?

It’s the Intel Iris 5100.

Intersting, in that in other game modes, Team Arena, Urban Terror, the latest beta with openGL2 running…all looks and functions splendidly.

When you say beta, do you mean a test build from ?

Yes, that’s the one.

Too, and unrelated, the real time shadows don’t seem to be working for me. GL2 is indeed running. Do the effects show up on the standard maps?

I’ve never seen the realtime shadows work on OSX.

Possibly related to your screenshot’s, when using the GL2 renderer try setting

r_mergeLightmaps 0

followed by a


Thanks for that blowFish. r_mergeLightmaps 0 did the trick. Cheers too for the os x info on the realtime shadows.

Does putting:

seta r_mergelightmaps “0”

into an autoconfig make that change a bit more automatic?

Have tried, but doesn’t seem to be working. Have to enter into the console each time.

Further, ran the windows version of the latest test build on a windows 10 boot camp partition and enabled GL2… still no realtime shadows. Perhaps this MacBook Pro with Intel Iris 5100 is simply not capable…os regardless?

As I understand it, realtime shadows are busted in general- I’ve seen screenshots with it working for a few people, but I’ve never once seen it myself.