Mac .app does not open. Might log file(s) exist?


#1

The Mac .app does not open, when I double-click on it.

Does anyone know if ioquake3 generates a log file, on each run (of the exe/app)?

If ioquake3 does generate logs (for postmortem analysis), any idea where they might be on MacOS? I tried looking in ~/Library/Logs, but didn’t see any files there containing “quake” (using a case-insensitive search).

Cheers,
– David L.


#2

The test build or the 2009-era build on the download page?


#3

This is the build from the download page (at https://ioquake3.org/files/1.36/ioquake3%201.36.dmg ) so, the 2009 era build?

Interestingly enough, the executable will run fine if I run it via the command line, with log data output to the launching terminal.

– David L.


#4

the download page advises you to immediately upgrade to a “test build” via these instructions http://wiki.ioquake3.org/Players_Guide

The download page builds will be replaced once we get autoupdating and signed builds working.


#5

The updated one does run ok. Thank you.

Do you know if there has been anything in the way of discussion, regarding updating the version on the download page? This seems like it might a worthwhile thing, in terms of helping new players get on board. I am, also, wondering if I might be able to help out, in some way.


#6

To add: I have seen posts and references to some of this. icculus’ work on the auto-updater stands out, for example, although admittedly, I am not terribly up-to-date on what might be missing. (I did see at least one merge, into Github, via https://github.com/ioquake/ioq3/pull/290 )


#7

We have a new volunteer sysadmin who may help us implement the backend part of this once some more pressing tasks are taken care of (moving the websites off of dreamhost, etc)


#8

Hmm, ok I can see you have the “test build” running now but just in case it’s ever needed there are some logs in this directory: ~/Library/Application Support/Quake3

Mine has files:

  • crashlog.txt
  • q3config.cfg
  • q3history

Also if an app doesn’t open in Mac have a look in System Preferences / Security Settings …
just in case macOS wants you to allow it. Gets me every time…