Issue with qvm and osp paks


#1

Hello, new to using ioquake3. Just started playing some q3 again and figured I’d give it a shot. So far so good, but there is one issue that I have noticed. I generally play on baseq3 servers with sv_pure 0 so I am able to use osp paks for enemy brightskins, crosshaircolor, scoreboard, stats etc. However, when I have the vm (with the qvm files in it) folder in my baseq3 folder, this doesn’t work. It seems to disable the osp paks completely. I had to remove the folder to get it working again, but I have noticed things like player shadows (cg_shadows 4) now doesn’t work anymore without it. Is there any workaround for this? I have tried setting vm_cgame game and ui to 0. Thanks in advance.


#2

vm_cgame 0 uses DLL, vm_cgame 2 uses QVM. In ioquake3 unzipped QVMs have priority over pk3s. So to use OSP pk3, you need to remove vm directory and set vm_cgame to 2.

For cg_shadows 4, make sure cl_renderer is set to opengl2. OSP cgame doesn’t seem to affect this.


#3

Thanks for the reply. I have vm_* set to 2 and cl_renderer is opengl2 but when I try to set cg_shadows 4 on a remote server, it does a vid_restart and just sets me back to 1. Seems to work fine on local though.