Ioquake3.x86 on Ubuntu 16.04 server


#1

I’m attempting to run ioquake3.x86, as opposed to the ioq3ded.x86. The reason is mostly for testing. I have partially converted an older q3 mod and am having varied results depending on what system I am using (I have several). So far the mod seems to run like it ‘should’ on windows. I run several servers on Ubuntu 16.04 server. The problem is, I get wonderful results on windows ioquake3.x86_64.exe… and next to nothing running the dedicated server on Linux… specifically lots of special effects and functions. The only way I’ve got the full unimpaired mod is running it with the ioquake3 exe. Running it with the ioq3ded knocks out not only graphics, but unexpected functions like regeneration. On to the question.
When I run ioquake3.x86 on Linux, it terminates with can’t set mode 3, unable to load OpenGL… is there a way to run ioquake3.x86 without OpenGL? This might help with a couple mods, and I just can’t abandon the raw speed of Ubuntu 16.04 server, for a desktop. Any thoughts are welcome. Thanks in advance.


#2

There shouldn’t be noticeable differences between running a server on ioquake3 and ioq3ded. I would recommend making it work properly when running on ioq3ded instead of figuring out OpenGL on a Ubuntu server.

You could try running it with ioquake3.x86.exe +set dedicated 1 to see if it’s somehow related to not running the client (still requires OpenGL).


#3

Thanks I’ll try that and let you know what happens.


#4

Same results. It’s trying to load the opengl, but there’s no graphics in the server at all. I’m going to look into this deeper. The only thing I can find on the net is about opengl problems, but not working without it… which seems to be the only difference between ioq3ded and ioquake3 as a server.


#5

The only difference I’m seeing between the ioq3ded and ioquake3 servers is ioq3ded carries no graphics, and apparently does not use opengl. The ioquake3 dedicated 2, does carry graphics so apparently that is the difference. Any thoughts about removing opengl from from ioquake3 server? Might be easier just making it work properly with ioq3ded, but I’ll go backwards and hard headed if it suits the situation.