ioquake3 on Debian doesnt start

i allways get the massage:

ioq3 1.36 linux-i386 Apr 12 2009
----- CL_Shutdown -----
Closing SDL audio device…
SDL audio device shut down.
RE_Shutdown( 1 )

recursive error after: User Interface is version 3, expected 6

i’ve no idea whats wrong, plz help,

Upgrade to a test build: and install the patch data:

thanks for fast help, but 1 problem left, when clicking the patch-data-link
i see a page with an eula and a ‘agree’ & ‘disagree’ link at the bottom.
clicking the agree-link does not open the patch zip link, instead i got redirected to

more Problems, i unzipped the test-build and copied all the files to /usr/local/games/ioquake3/ , running ioquake3 still produces the same errors, tryig to run /usr/local/games/ioquake3/ioquake3.x86_64 directly also does not work, file not executlabe tells the shell to me, even thou the file is executeable for all users.

Are you on a 64bit OS and CPU?

model name : Intel® Pentium® Dual CPU T2370 @ 1.73GHz

if you still get the same errors with the test build and patch data installed, then the patch data is still not being found by ioquake3.

Try to place game data files in ~/.q3a. You should at least have there baseq3 directory with pk3 data files copied from install cd + data files from 1.32 point release.
I’m successfully running ioq3 client on arch linux and two servers on debian.

i686 is 32-bit

You’ll need to use / build the 32-bit version

1 Like