Ioquake3 no sound at all


#1

As the title says I don’t have any sound at all in the game (no sound effects or music) and it has been driving me up the walls recently. So I decided to ask here, maybe someone had something like this happen to them and have a solution?

Any help is greatly appreciated!


#2

Are you using a recent test build?

Can you post the console log? Run ioquake3 and open the console using shift+escape and type condump log.txt and press enter. The log will be at

  • (Windows) %APPDATA%\Quake3\baseq3\log.txt
  • (macOS) /Users/YOURNAME/Library/Application Support/Quake3/baseq3/log.txt
  • (GNU/Linux) /home/YOURNAME/.q3a/baseq3/log.txt

#3

Okay, apparently I am dumb! After creating the log and paying closer attention to what it was saying I found the problem and fixed it!

Thank you for your help either way!


#4

Can you maybe share what you did to fix it? I’m on windows 10 and dont have any sounds at all, neither in game, menu or videos.


#5

You need the OpenAL64.dll in your ioquake3 folder.


#6

Perfect, works like a charm, thanks!!!


#7

You’re welcome! :grinning:


#8

Same problem here. Where do you find the openAL64.dll?


#9

Hmm, I wonder why fallback internal mixer isn’t working when OpenAL dll is missing.

For OpenAL32.dll / OpenAL64.dll use the latest OpenAL Soft. Download the openal-soft-*-bin.zip on the page and rename the openal-soft-*-bin\bin\Win32\soft_oal.dll to OpenAL32.dll and openal-soft-*-bin\bin\Win64\soft_oal.dll to OpenAL64.dll and move them to your ioquake3 directory.


#10

I’m curious if the people having problems are using a 5.1/7.1 channel configuration on their system. I know there are problems in this configuration, but I’m not sure if it is because of the recent SDL update with WASAPI backend or if it was already broken before.


#11

Based on a brief test, before the SDL update sound works in a 5.1 and 7.1 configuration but only plays on the 2 front speakers. After the SDL update there is no sound at all when the system is in a 5.1 or 7.1 configuration.


#12

I changed my audio settings from 5.1 to stereo and now I have sound on the 64 version. Funny, the 5.1 still had sound on the 32 version. THX!


#13

Ah, it was indeed because of surround sound. Thanks Chomenor. It should be fixed in test builds now. It still only plays on the front two speakers though. OpenAL Soft should support surround sound correctly.