How to successfully connect to a Rocket Arena 3 server locally

I’ve been trying to connect to a local server for RA3, but I’m getting a “Mismatch” error. I’ve tried with RA3 1.8, 1.76, and every time I tried to connect I’m getting a mismatch error.
However, if I try to connect to another server, things work just fine and I’m able to connect.
So, I’m suspecting that I’m missing something when creating my RA3 server.

Any help would be appreciated.



You need to run 32-bit version when creating the RA3 server.
I used to create the dedicated server with this file: ioq3ded.x86_64

After I installed the ioquake3 32-bit version I started the dedicated server with this other file ioq3ded.i386 and things worked just fine, I was able to connect to my own server. And it doesn’t matter which engine the client has, it can be 32-bit or 64-bit. What it is important is that you create the server with 32-bit.

Here it is an example for the command line to create the server (working for me):

./ioq3ded.i386 +set fs_game arena +set vm_game 0 +set sv_pure 0 +bot_enable 0 +set dedicated 1 +exec server.cfg

Thanks MAN-AT-ARMS for your help!


1 Like