How do I run in fullscreen with lower resolution (scaled)

I’m trying to run fullscreen at a lower resolution. My little pi 4 can’t handle it at my desktop res with r_mode -2.

Here’s the command I’m running:

quake3 +set r_mode -1 r_customHeight 486 r_customWidth 864 r_fullscreen 1

Also tried dropping r_fullscreen 1 from the command and using the in-game console to run

r_fullscreen 1
vid_restart

Also didn’t work. It keeps it in windows mode.

System Specs:
Raspberry pi 4B
OS: Ubuntu 20.04, but also tried Raspian Buster
Display: BenQ MH535FHD 1080P (1920 x 1080p)

I am surprised the pi 4 won’t run ioquake3 at 1080p, but I suspect the monitor doesn’t support the 864 x 486 mode which is why it is popping out to windowed mode. You could try 720p, that’s 1280x720

As far as I know we don’t offer any internal render resolution, but that wouldn’t be a bad thing to offer. Especially for users who are running an RPI at 4K.
Is this a version of ioquake3 you’ve compiled yourself or a package provided by the distribution?

@TimeDoctor, I’m pretty new to pi and linux, so I wouldn’t be surprised if there are some things I should be doing that are intuitive to most veterans. Even quake1 on quakespasm lags on anything higher than 1024 x 768.

I installed via the distribution sudo apt install quake3 and used game-data-packager with my GOG download. Probably wouldn’t hurt to attempt compiling myself. I had some errors when I tried that method on Buster. Haven’t tried on Ubuntu yet.

Thanks for your suggestions. I’ll give them a try within the next week or two.

It sounds like your OpenGL acceleration is disabled.

@TimeDoctor I tinkered around a little more. I’m able to get this working at least at 640x480 in fullscreen mode on Raspian Buster with just quake3 +set cl_renderer opengl2 r_mode -2 and setting the resolution in game.

I initial understanding of r_customWidth and r_customHeight was that those controlled game resolution, not window size.

Anyway, thanks for the tips! I didn’t know I needed to do something to enable opengl on pi. Quake 1 is smoother now. The only issues I have now are completely unrelated to ioquake.

For anyone who happens to stumble upon this thread with the same questions I had, enabling opengl in Raspian Buster was as simple as:

  • sudo raspi-config
  • 7 - Advanced Options
  • A6 GL Drivers
  • Select GL (Full KMS) or GL (Fake KMS). Most pi users seems to report better performance with “fake” but both should work
1 Like