Game mismatch: This is a QuakeArena-1 server

#1

I am not able to connect to a couple of quake server.
When I try to connecto I get the error message “Game mismatch: This is a QuakeArena-1 server”

SERVER WHERE I GET THE ERROR
/connect exy.it.cx:27965

Searching the error on internet I found a guy with same error when try to connect to the following server
\connect 88.198.221.98:27960
I tried and I get the same

please help me.
thanks

#2

The message happens when ioquake3 client from July 29 2011 or later connects to a server is based on ioquake3 source code from July 12 2011 to before July 29 2011.

In order to connect to the server, start ioquake3 from a command prompt, shortcut, or batch file using:

ioquake3.x86.exe +set com_gamename ""

This will allow connecting to all servers.

Drawbacks include not being properly separated from standalone games and if you host a server it probably won’t be listed on the official Q3 master server. For general quake 3 player usage, clearing com_gamename is fine.

It’s possible to fix this in the ioquake3 client but it seems odd to add hacks for a server protocol that existed for 17 days, six years. It kind of haunts me though. :frowning:

#3

Thanks for your reply , your suggest works fine. I create a batch to start the ioquake client.

I would like share with you and with community an update at this case adding more info.

  1. The program is named ioquake3.x86_64.exe and it is x64, I didnt download it from the ioquake official website, but from a link found on internet…it was just a folder ready to use.

  2. After the post I remembered it and I yesterday I download the setup creating a clean installation.
    Well ,I can connect to eXy server .

[OT] With a clean installation I have some trouble:

  • autoexec.cfg not invoked (I renamed all autoexec.cfg and a manual exec autoexec.cfg does not return fle not found!
  • sound is strange (pad, rockets… seems like reverbered.

Let me open another topic

thanks for 1st help

#4

Regarding the sound issue; either set s_useOpenAL 0 or replace Creative’s OpenAL32.dll included with ioq3 1.36 installer with OpenAL Soft.