Can't launch ioquake3 in macOS Sierra


#1

From the top sorry for my weka ENG.

Hi, I’m totaly new in MACos and i want to install ioquake. ALready purchased GOG Quake 3 and downloaded ioquake. I copyed ioquake and then copy pak0.pk3[479,5mb] into ioQuake>baseq3. Then i launched ioquake3fe-1.36.app with “test” and game doesen’t launch, new window popup and show this:

ioq3 1.36 macosx-i386 Apr 22 2009
----- FS_Startup -----
Current search path:
/Users/krzysztofszczepaniak/Library/Application Support/Quake3/baseq3
/var/folders/gw/c5prp6wj60sbc_3shnffnfcr0000gn/T/AppTranslocation/FCAAD59A-5F0F-47F4-969C-7BB995B38724/d/ioquake3fe-1.36.app/Contents/MacOS/baseq3
/var/folders/gw/c5prp6wj60sbc_3shnffnfcr0000gn/T/AppTranslocation/FCAAD59A-5F0F-47F4-969C-7BB995B38724/d/baseq3

----------------------
0 files in pk3 files


pak0.pk3 is missing. Please copy it
from your legitimate Q3 CDROM.


Point Release files are missing. Please
re-install the 1.32 point release.


Also check that your Q3 executable is in
the correct place and that every file
in the baseq3 directory is present and readable.
You need to install Quake III Arena in order to play

#2

You need to move the ioquake3 directory out of the download folder. Moving it to /Applications or anywhere else is fine. This is needed to disable macOS’s AppTranslocation security feature that prevents pk3s from being accessed.

You should also upgrade from the 2009 release to a test build.


#3

Now works, but have another questions. Can I play on external LCD? Can you recomend “addons” to get better textures and AI?

Thank you a lot for your help :slight_smile:

EDIT:
Found how to set External monitor as primary, but ultrawide works by cuting 3/4 of my weapon :E


#4

Very high quality rendering settings

These settings can make the game look better with the existing textures.

You can add them at the bottom of your config file at

/Users/krzysztofszczepaniak/Library/Application Support/Quake3/baseq3/q3config.cfg

or enter them in the console individually. The console can be opened in-game by pressing shift+esc.

seta r_mode -2 // make game use desktop resolution
seta r_picmip 0 // full texture detail
seta r_flares 1 // enable light flares
seta r_lodBias -2 // don't use lower detail models far away
seta r_subdivisions 1 // smoother curves
seta r_ext_texture_filter_anisotropic 1 // enable anisotropy texture filter
seta r_ext_max_anisotropy 16 // 16x anisotropy texture filter
seta r_ext_multisample 4 // use 4x anti-alias (opengl1 renderer)
seta r_ext_framebuffer_multisample 4 // use 4x anti-alias (opengl2 renderer)

seta r_lodCurveError 10000 // smoother curves far away (cheat protected)
seta r_forceSun 1 // cast shadows from sun (opengl2 renderer, cheat protected)

Cheat protected values only work when you start a map using devmap q3dm7 in the in-game console. They get reset when you play a non-cheat map so you may need to reenter them often.

ioquake3 Addons

High resolution textures: https://ioquake3.org/extras/replacement_content/
My widescreen HUD mod (fixes the view weapon too): https://clover.moe/flexible-hud-for-ioq3/
Better AI: Maybe the Brainworks mod? I haven’t actually used it personally. Bug fixes for bots made to ioquake3’s baseq3 code are included in my HUD mod though.

Alternative

I have project based on ioquake3 named Spearmint which is not compatible with Q3 code mods or servers. It has many additional improvements to the bot AI, widescreen HUD support built-in, and a “very high quality” graphics preset in the menu to handle most the above settings. It’s compatible with the high res textures pack too.


#5

ioquake3 with mod works perfect, I tried to install Spearmint with some issues and I give up. I sincerely thank you for the help and useful links, thanks to you I can relax by killing bot’s :wink:


#6

Being new to Mac in general, I also seem to have that issue. I tried copying the pak0.pk3 from the CD to my iMac, and I get an error when I try to launch, that it can’t find the pak0.pk3. I never heard of this. How can I disable that so I can copy the .pk3 without issues onto my Mac in order to run Quake 3 ? I would really appreciate some help. Thanks in advance.

Wolf


#7

If ioquake3 is in the downloads folder, move it to /Applications/ioquake3/.