Can I see the MOTD on the client side?


I am using ioq3 148603c95162468bf14a30d92593312b3e6570b7 [1] on the server side (32-bit) and on the client side (64-bit).

I set a MOTD (Message Of The Day) on the server side:
g_motd "Welcome to the YuGiOhJCJ's server!"

However, I don’t see it on the client side.

I posted an issue [2] on the GitHub of ioq3 where I am showing some screenshots without the MOTD.
In an answer of robo9k, we can see a screenshot where the MOTD is displayed.
He explained how he did so I followed what he did but unfortunately I am still unable to display the MOTD on my client.

Any idea about what I am doing wrong please?

Thank you.
Best regards.


Has it been set like

seta g_motd “message here”

as it’s own line in the CFG

On the server side, I am not using a CFG file.
That’s how I run the server:
/usr/games/quake3/ioq3ded.x86 +seta g_motd "^1MOTD" +map q3dm6 &

Any idea why my client can’t see the MOTD please?

Start up argument parsing is buggy. +seta is completely ignored. +set only allows value to be one word (which requires escaping quotes using +set g_motd \"hello world\" on Unix-like platforms). The best workaround is +g_motd No Quotes! which should work all platforms and version of Q3.

These issues are now fixed in ioq3 git master. When the test build gets updated the Linux server can use +set g_motd "hello world" as one would traditionally do on Windows. All platforms can now use +seta and don’t have to use quotes for +set.


OK so here is how I run the server now:
/usr/games/quake3/ioq3ded.x86 +g_motd MOTD +map q3dm6

As you can see:

  • I am not using anymore quotes
  • I am not using anymore +seta
  • I am using +g_motd

But on the client side, I still don’t see the MOTD.

Any idea why?

Oh. +g_motd MOTD only works if you first add seta g_motd "CREATE THE CVAR" to /home/USERNAME/.q3a/baseq3/q3config_server.cfg. See solution 3 below.

Any one of these options should allow you to set g_motd. If one does not work, please try the others.

Solution 1. Use +set g_motd \"MOTD 123\".
Solution 2. Rebuild ioq3 git master and use +set g_motd "MOTD 123" or +seta if you want it archived instead of having to be set at start up each time.1
Solution 3. Start the server and run seta g_motd blah in the server console then quit. In the future you can use +g_motd MOTD 123.

1 You really only need to run seta g_motd blah once, which adds it to q3config_server.cfg. It keeps the archive settings later even if you use +set.

1 Like

Wow thanks a lot it works.
I add the seta g_motd "CREATE THE CVAR" line to the /home/USERNAME/.q3a/baseq3/q3config_server.cfg file.
I run the server:
/usr/games/quake3/ioq3ded.x86 +g_motd MOTD +map q3dm6 &

And here is the result on the client:

I see the MOTD :smiley: