Bot load Problem


#1

I’m offering a gig to somene to properly set up ioquake3 the updated from:


On my Debian 8 x64 (jessie) server, for excessiveplus mod I have all the mod settings set all that’s needed is properly set up the updated ioquake3 in possibly 64 bit mode … I can pay by pp , or anything else. Let me know thanks! .


#2

it’s really very straightforward http://wiki.ioquake3.org/Sys_Admin_Guide


#3

ive burned 1tril brain cells trying that . I just cant for what ever reason I do something wrong , Plus I’m more interested in having this:

used in 64 bit , I can pay up to 50$ for someone who could do it for me , thanks.


#4

The linux sys admin guide gets the source code from https://github.com/ioquake/ioq3 and compiles it. On Debian amd64 (aka x64), it will compile x86_64 (aka x64) by default.

You haven’t provided any details on the issues encountered, so I don’t know if this is the issue you had:

When I set up a game server on Debian Jessie a few months ago the ioq3 Sys Admin Guide did not work. Running screen after su - ioq3srv would error about tty being inaccessible. Cannot open your terminal '/dev/pts/0' - please check.

The direct solution was to run script /dev/null before running screen, but it’s kind of annoying to have to run each time.

After research I ended up with creating /home/zturtleman/screen_ioq3srv.sh. I run it as my login user to either start the game server or reattach to already running game server in screen.

#!/bin/sh

# Start or reattach to screen session as user ioq3srv
# the start_server.sh script is only run if session is not running

# Press Ctrl+a then d to detach from screen.

sudo -u ioq3srv script -q -c 'screen -d -R -U /home/ioq3srv/start_server.sh' /dev/null

#5

zturtleman can you install for me ? $50 .


#6

yeah, I can try to get it to run.


#7

oh man , I’m so proud , I did it! lmao . Thanks zturtleman but I finally got it


#8

Ah, okay cool. Glad it worked out.


#9

question , I have seta g_botsfile “bot.txt” and the bot file only in baseq3
inside bot,txt I have

{
name ^r^o^x3C7202#CB#C9#CC#CC#C5#D2^R^o^xC53D00#CB#C9#CC#CC#C5#D2
model xaero
aifile bots/sneakybot_c.c
arenaLord 5
}

{
name ^l^xEAF11F#1D^s^f^x8B8F17#D4^F#C5^f#D2^F#ED^s^l^xEAF11F#1F
model orbb
aifile bots/sneakybot_c.c
arenaLord 5
}

This works with q3ded , but not with io , ideas?
I’m using cmd , seta g_botsfile “” also tried set , didn’t work


#10

Alternatively…If you don’t want to use screen, you should just be able to run in the background like this:

./ioq3ded.x86_64 +set dedicated 2 < your commandline arguments here > 2> /dev/null &

And for status:
ps auxwww | grep $USER | egrep “ioq3ded” | grep -v grep


#11

server is running fine I use a .sh string to load it . Problems is with the download timing out and the bot problem , my main concern is the download , I have the threat open is one of the top ones about the download issue