A brief presentation and a little question

Hi everyone. I am an Italian mathematician and software developer and in my free time I work on a couple of projects of mine involving ioQuake3 and id Tech 3 mapping in general. But, above all, I am a longtime Quake 3 player and ioQuake3 has always been my source port of choice; I hope one day I’ll be able to release at least one of these projects, as free and open source software, in order to give back something to the beautiful communities around classic id Software first person shooters.

I always try to solve technical doubts and issues by myself, but there’s one little thing I can’t figure out: is there a way in ioQuake3 to avoid the Hall Of Mirror effect when noclipping out of a map and looking at it from the outside? Clearly the caulk texture isn’t drawn by the engine, but I’m trying to understand if there is a cvar or some other setting that would let the player look at the external parts of a map with a “clean” background.

Anyway, huge thanks and sincere congratulations to the developers of ioQuake3 for this fantastic source port of an already fantastic game engine.

Davide

2 Likes

You can set r_clear 1 to clear the screen background. It’s magenta and not configurable though. This only works when loading the map using devmap <mapname>.

2 Likes

Thank you for the answer. I had already tried that command, but I can’t get it to work, even if followed by a vid_restart. Is it a feature added recently to the engine? The version I’m using could be one or two years old…

It’s a test map of mine, played using the devmap command. In the map every brush face non visible from the playable area is caulked, and in order to simulate level-wide fog the entire map is enclosed in an external box which exactly contains a huge fog cuboid. The box is entirely textured with caulk, I supposed this could be the cause, but I tried to retexture the box internals with a “normal” texture and nothing changed…maybe I’m overlooking something?

r_clear 1 was broken with default settings until recently (OpenGL2: Fix r_clear when using HDR/FB-MSAA · ioquake/ioq3@f7c12a1 · GitHub).

You could try cl_renderer opengl1;vid_restart .

2 Likes

Thank you again, this one has worked!

At this point it’s clear what the problem was: the version I’ve been using for the last year and half doesn’t have that fix and, in fact, I was using the opengl2 renderer all the time.

I use the new renderer because some time ago I experimented a little bit with normal mapping (and I got it to work, thanks to the docs on GitHub), but r_clear 1 works fine with opengl1 and that’s enough in order to take a screenshot of the map seen from the outside from a far distance. But eventually I’ll update ioquake3 anyway.

Thank you one more time!

Davide

1 Like